The attached 23 pages are a great reference on many tips and tricks within Excel for ALL LEVELS.
Thank you to Al Momrick for allowing us to use this document and other supplement spreadsheets for you
to practice on.
I have also included a powerpoint that is VERY basic excel skills just in case any of you need that.

1

Microsoft Excel
This document is usable for any of the excel documents attached in the file. Typically, there are three levels
of training. Each item below will be labeled to inform you of what class provides training on that topic.
Beginner: u
Formulas and Functions: n
Cool Tips & Tricks: ®
Absolute Value--n
1.
2.

=ABS(cell) will give the absolute value (positive number) for a cell.
In conjunction with sum formula =ABS(cellA+cellB)

Absolute Positioning--u®
1.

Use dollar signs before the row and column portions of a cell address (i.e., instead of A5, enter $A$5).
Shorter Shortcut: With the cursor positioned within the cell area in the formula bar, press F4 to cycle through options
of using absolute reference on both or either column or row.

AND function--n
1.

=AND(condition1, condition2) will return a value of TRUE if both conditions are true, otherwise will return FALSE.

AutoComplete--u
Excel will attempt to complete your data entries based on previous entries made.
1. Begin entering text or a value.
2. If Excel recognizes your entry, it automatically suggests it.
3. If Excel guesses correctly, press ENTER to accept it. If you want to enter something else, just continue typing and
ignore Excel's guess.

AutoCorrect: Add Entry--®
1.
2.
3.
4.
5.
6.
7.

Click on Excel globe in upper-left corner.
Click on “Excel Options” button in lower-right corner.
Click on “Proofing”
Click on “AutoCorrect Options” button.
In the “Replace” entry box, type in the abbreviation to use for Auto-correcting.
In the “With” entry box, type in the text to be substituted.
Click the “OK” button.

AutoFill for Dates or Numbers--u®
1.
2.
3.

In consecutive cells, type in the first two values of the list.
Select the two cells
Click-drag the dot in the lower-right corner of the range down for the desired number of cells.

AutoFill for Days or Months--®
1.
2.
3.

Type in the first day (or month), abbreviated or full text and press [ENTER].
Click back on the cell.
Click-drag the dot in the lower-right corner of the cell for the desired number of cells.
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AutoFill for Text--u®
·
·

Right-clicking a cell and selecting Pick from Drop-Down List will bring up potential AutoFill entries.
Pressing Alt-Down Arrow will bring up potential AutoFill entries.

AutoFilter--®
1.
2.
3.
4.
5.

Click within the range.
Click on Home Tab.
Click on Sort & Filter
Click Filter
Using drop-down arrows, make desired selections.

Shortcut:
1. Right-click on a value in a cell.
2. Click on Filter.
3. Click on Filter on Selected Cell’s Value.

AutoFilter—Restore--®
Returns a database to list all records.
1. Click drop-down of a filtered column.
2. Click ‘Select All’ .
3. Click ‘OK’, this will list back all the original values.

AutoFilter—Shutting Off--®
1.
2.

Click Sorting & Filter
Click Filter.

AutoSave (AutoRecover)
1.
2.
3.
4.
5.
6.

Click on the Windows button.
Click on Excel Options.
Click the Save menu choice.
Click the box for “Save AutoRecover information every”
Click the minutes indicator to the desired setting.
Click OK button.

AutoSum--n
·
·
·

Clicking AutoSum twice will sum the values either directly above or to the left of the current cell.
Clicking AutoSum once will identify which cells it assumes you would like summed. You may change the cell range and
click the AutoSum button a second time to confirm the range.
Pressing the Alt-= (equal sign) will identify which cells it assumes you would like summed. You may change the cell
range and press ENTER with the desired range to sum.

AVERAGE function--n
1. =AVERAGE(cell range)
2. Example =AVERAGE(A1:A3, A5) for average of cells A1, A2, A3, A5.
Note: AVERAGE will not include blank cells in averaging, but WILL include 0’s.

Borders-Selecting--u
1.
2.
3.

Highlight the area desired to add borders.
Right click, and select ‘Format Cells’ from the menu that appears.
Click on the ‘Border’ tab.
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4.
5.

Select the style, color, and presentation of the border you wish to add.
Click ‘OK’ to return to your spreadsheet.

Carriage Return within a Cell--®
To force a return within a cell, press Alt-Enter.

Cell Selection—Non-contiguous--u®
To select non-contiguous cells, hold down the Ctrl key as you select them.

Chart Creation--u®
1.
2.
3.
4.
5.

Highlight the cells desired to be charted.
Click on the ‘Insert’ tab.
In the ‘Charts’ toolbar, select the type of chart best suited for your information. (Each type of chart has a dropdown
bar with more detailed versions of each chart)
The chart will appear on your spreadsheet; you can move the chart by left clicking and dragging.
Once the chart is in position, click anywhere on your spreadsheet.

Chart Deletion (Shortcut):
1.
2.

Click on the chart to be removed.
Key the ‘Delete’ button on keyboard.

Circular Reference
When an error refers to a “circular reference” it means that the formula you are entering into a cell refers to its own
address in the formula. For example, if you enter the following formula into cell A3 you will get a circular reference: =A1+A2+A3.
A3 cannot be the resulting location and be part of the formula at the same time.

Clear Format
1.
2.
3.

Click on the cell(s).
Click on the drop-down arrow next to Clear on the Editing section of the home tab.
Select Clear Formats.

Column Delete--u
1.
2.
3.

Select the column headings of the columns to delete.
Select the ‘Home’ tab.
Select the ‘Delete’ icon in the ‘Cells’ section of the toolbar.

Column Hide & Unhide--u
1.
2.
3.
4.
5.

Select the column(s) you want to hide.
Select the ‘Home’ tab.
In the ‘Cells’ section, select the “Format” icon.
A dropdown will appear, select “Hide&Unhide”
Click “Hide Columns” or “Unhide Columns”

Column Insert--u
1.
2.
3.

Select the column headings where you want the insertion to take place.
Click the ‘Home’ tab.
In the ‘Cells’ section, click ‘Insert’ button

Column Width--u
1.

Select the column(s) you wish to adjust.
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2.
3.
4.
5.

Select the ‘Home’ tab.
In the ‘Cells’ section, select ‘Format’
Click ‘Column Width’ from the dropdown that appears.
Type in the width (in characters) that you wish the column(s) to be.

OR
1.
2.
OR
1.
2.

Drag your cursor to the border separating column headings.
Left click and drag column to the desired width.
Drag your cursor to the border separating column headings.
Double-click. The column-width will automatically set to the widest entry in that column.

Column Width—within Print Preview--u
1.
2.
3.
4.
5.
6.

Click the Windows button.
Click Print
Click Print Preview.
In the Print Preview toolbar at the top of the screen, click Show Margins button.
Across the top of the page, a row of black column handles appears. Click-drag the handles to the left or the right to
change the width of the columns on the page.
When your page looks the way you want it to look, click either Print or Close Print Preview.

Comments—Add--®
1.
2.
3.
4.
5.

Click cell for comment.
Right click on cell.
Select ‘Insert Comment’
Type in desired comment.
When finished, click back on your spreadsheet.

You'll notice that a small red triangle will appear in the upper-right corner of the cell that contains the comment. As the cursor
moves into the cell, the comment will appear.

Comments—Delete--®
1.
2.

Right click the cell with the comment.
Click ‘Delete Comment’ from the menu that appears.

Comments—Edit--®
1.
2.
3.
4.

Right click the cell containing the comment.
Select ‘Edit Comment’ from the menu that appears.
Make edits as desired.
Click back on your spreadsheet, and the comment will again appear as a small red triangle.

Concatenate--n
1.
1.

=CONCATENATE(text1, text2,…) ENTER where text1, etc. are text within quotes or cell addresses.
or
=cell1&cell2 ENTER

Conditional Formatting--®
1.
2.
3.
4.

Select cells to format.
Click on Data Tab.
Click on Conditional Formatting
Select desired formatting options.
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Copy/Paste shortcuts--u®
5.
6.
7.
8.

Click on the desired cell.
Press Ctrl-C to copy the contents to the clipboard.
Move to desired cell.
Press Ctrl-V to paste.

Shorter shortcut:
1. Click and hold mouse-button down on border of cell to be copied.
2. Press Ctrl button.
3. Drag mouse to desired cell location.
4. Release mouse button.

Copy Formats--®
1.
2.
3.

Click on the cell that has the desired formatting.
Click on the Format Painter tool on the button bar.
Click-drag the cells to be formatted.

Alternate Use: If you double-click the Format Painter button, it will remain in use until you click it again.

Copy Down--u®
After entering a cell’s contents and hitting ENTER, the cell cursor moves down one cell. Press Ctrl-D to copy the formula
into the next cell.

Copy Values--®
1.
2.
3.
4.

Select column of cells.
Position cursor on right border of column (you will see four-headed arrow).
Right-click and drag to the right one column.
Select “Copy Here as Values Only”

You can now safely remove the original column that had formulas in it.

COUNT Function--n
1.

=COUNT(range) to get a count of cells that contain numeric values.

COUNTA Function--n
1.

=COUNTA(range) to get a count of cells that contain text or numeric values.

COUNTIF Function--n
1.

=COUNTIF(range,xxx) where xxx equals a number. Alternatively, you can search for alpha/numeric characters by
enclosing the search criteria within quote marks (i.e. “ABC”).

Custom Lists--®
1.
2.
3.
4.
5.
6.
7.
8.
9.

Click Office Globe in upper-left corner.
Click Excel Options button.
On the “Popular” tab, click “Edit Custom Lists”
Enter in values in “Entries” box.
Click “Add” button.
Click OK button.
Click OK button.
Type in one of the values in a cell. Press ENTER.
Click back on that cell.
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10. Click-drag from black dot in lower-right corner downward.
11. Release.

Date calculation--®
To calculate the difference--in days--between two dates:
1. Type in the two dates in separate cells.
2. Click on desired cell for resulting answer.
3. =N(location of first cell date) - (location of second cell date) [ENTER].
The N function converts the results to numbers so you get the number of days (instead of a date) as your difference, and so you can
use the difference as a number in other equations.
Alternate method:
1. Type in the formula as follows:
=”mm/dd/yy” – “mm/dd/yy” (including the quote marks and slashes)

Date entry--u
Type in dates with dashes (-) or slashes (/). Do not assume that formatting will place these characters into your date fields.

Date Entry—Century--®
Only two digits are necessary for dates from 1930-2029. For all other dates, 4 digits are required.

Date formats--u
If you enter a date into a cell and see a number rather than the date, format the cell for date entry.
1. Right click cell and select ‘ Format Cell’.
2. Select the ‘Number’ tab.
3. Click ‘Date’ as category.
4. Select the desired format from menu that appears.
5. Click ‘OK’.

Date Formats—Customized--®
To create a customized format for dates.
1. Select the cells to be formatted.
2. Right click and select ‘Format Cells’.
3. Click the ‘Number’ tab.
4. Click Date category.
5. In the Type entry box, select the desired formatting.
6. Click OK button.

Date Sequences--®
To create a series of dates evenly spaced apart:
1. Enter the first two dates in consecutive cells.
2. Highlight both cells.
3. Click-drag the dot in the lower-right corner of the range of cells downward for as many additional cells that are desired.

Date—Today’s--®
Press Ctrl-; (Control key and the semi-colon) to have today’s date entered into the current cell.

DOLLAR Function--n
1.

=DOLLAR(number, decimals) or =DOLLAR(cell, decimals)
Will display as currency left-justified
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Duplicate Records (removing)-- ®
1.
2.
3.
4.
5.
6.
7.

Click anywhere within data to be de-duplicated.
Click on Data tab.
Click on Remove Duplicates.
Click “Unselect All” button.
Click on desired column.
Click OK button.

Editing a Formula or Function--u
1.
2.
1.
2.
1.
2.

Click in the cell to edit.
Click in the formula bar to edit.
or
Double-click the cell to edit.
Make the changes on the cell.
or
Click the cell to edit.
Press F2.

Editing Multiple Worksheets at One Time
1.
2.

Press Shift-Worksheet Tab to select the desired number of worksheets.
Make desired entries that are to be duplicated on selected worksheets.

Make sure to de-select all worksheets before continuing with individual edits.

End of Worksheet--u
To move to the last cell entry in a worksheet, press Ctrl-End.

Elapsed Time--®
=(endtime – begintime) * 24

ENTER—Changing Default Direction of Entry of Data--®
1.
2.
3.
4.
5.

Click on the ‘Options’ button (icon in the top left of screen).
Click on ‘Excel Options’ button.
Click on ‘Advanced’ found in the menu on the left of Options screen.
The top option allows you to choose which direction you want the selection to move after pressing enter.
Click ‘OK’.

ENTER—Changing Direction of Entry of Data
1.
2.

Select the cells for data entry.
As you type entries, if you end the data entry by pressing ENTER, the cursor will move downward in the group of cells.
If you press TAB, the cursor will move to the right in the group of cells. Holding the Shift-key down when pressing
ENTER or TAB will reverse the direction.

Errors in Entry--u
If you encounter errors as you are keying in a number or formula, simply press ESCape key to negate the entry.

Error Messages
Here is a list of some error values and their meanings:
· #DIV/0! -- Appears when the formula calls for division by a cell that either contains the value 0 or, as is more often the
case, is empty. Division by zero is a no-no according to our math.
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·
·
·
·
·

#NAME? -- Appears when the formula refers to a range name that doesn't exist in the worksheet. This error value
appears when you type the wrong range name or fail to enclose in quotation marks some text used in the formula,
causing Excel to think that the text refers to a range name.
#NULL! -- Appears most often when you insert a space (where you should have used a comma) to separate cell
references used as arguments for functions.
#NUM! -- Appears when Excel encounters a problem with a number in the formula, such as the wrong type of
argument in an Excel function or a calculation that produces a number too large or too small to be represented in the
worksheet.
#REF! -- Appears when Excel encounters an invalid cell reference, such as when you delete a cell referred to in a
formula or paste cells over the cells referred to in a formula.
#VALUE! -- Appears when you use the wrong type of argument or operator in a function, or when you call for a
mathematical operation that refers to cells that contain text entries.

EVEN and ODD Functions--n
=EVEN(cell) returns the next even number of the selected cell.
=ODD(cell) returns the next odd number of the selected cell.

Exponential Equations--n
To raise a number to a power
= x ^ y (where x is the number and y is the power) ENTER
or
=POWER(x,y) ENTER

File Directory—Changing the Default Directory
1.
2.
3.
4.
5.

Click on the ‘Options’ button (icon in the top left of screen).
Click on ‘Excel Options’ button.
Click on ‘Saved’ found in the menu on the left of Options screen.
In the “Default File Location, type in the directory you wish to have as the new default.
Click ‘OK’.

Fill Down--u®
To fill cells BELOW the entry with the same entry:
1. Select a range that includes the cell containing the entry AND as many cells below the entry as you want to fill.
2. Press Ctrl + D.
Shorter Shortcut:
Double-click the little square in lower-right corner of the cell to be copied downward. It will copy the contents downward
until it comes to a blank cell.

Fill Handle Copying--®
Click-drag the fill handle in any direction to copy that cell’s contents to other cells.

Fill Right--®
To fill cells TO THE RIGHT of the entry with the same entry:
1. Select a range that includes the cell containing the entry AND as many cells to the right of the
entry as you want to fill.
2. Press Ctrl + R.

Filtering--u®
1.
2.

Select the cells containing data.
Select the “Home” tab.
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3.
4.
5.
6.

Within the “Editing” section, click on “Sort & Filter”.
Click on Filter.
Click the drop-down arrow on the desired column.
Make a choice from the resulting list.

To see all the records:
1. Click the drop-down arrow.
2. Select All
or
1. Click the Sort & Filter menu.
2. Click on Filter (to shut off Filtering).

Filtering: Alternate Method--®
1.
2.

Right-click on cell containing the data you wish to filter on.
Point to Filter option and move mouse across to “Filter by Cell’s Selected Value”

Find--u
1.
2.
3.
4.
5.

Select the ‘Home’ tab.
Click on ‘Find & Select’ drop-down arrow in the ‘Editing’ section.
Click on ‘Find’
Type what you are searching for after ‘Find What :’
Click ‘Find All’ for multiple searches, or ‘Find Next’ for an individual search.

Shortcut: Instead of steps 1-3, press Ctrl-F.
If you have multiple searches to perform, the “Find What” drop-down box contains your previous search entries.

Fit To Page
Shrinks the print area to enable it to print on a desired number of pages.
1. Click on the ‘Page Layout’ tab.
2. In the “Scale to Fit” section, click the drop-down arrow next to “Height”.
3. Select the number of pages you want in the final printout.

Fixed Decimals--n
1.
2.
3.
4.
5.
6.

Highlight the area you want to set number of decimal places for.
Click the “Format Cells” menu option.
Right click, and select the ‘Number’ tab.
Select the ‘Number’ category.
Change the number of decimal places to your desired number.
Click ‘OK’.

Font—Changing Default
1.
2.
3.
4.
5.
6.
7.

Click the ‘Options’ menu (the icon at the top left of screen).
Click “Excel Options” button at bottom-right of screen.
Click ‘Popular’ on left of screen.
In the area designated ‘When creating new workbooks…’, find the “Use this Font” drop-down.
Click the drop-down.
Change desired font style, size, etc.
Click ‘OK’.

Form Tool--®
1.

Click Form Tool on customized Quick Access Toolbar.
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2.

Enter in records.

Formatting Cells--u
1. Select the cells or range to format.
2. Right-click the selection and click on “Format Cells”.
You will see a dialog box where you can make any desired formatting changes.

Formatting Cells—Custom Formats (i.e., leading zeroes):-- ®
1.
2.
3.
4.
5.
6.

Select the cells or range to format.
Right-click the selection and click on “Format Cells”
Click the ‘Number’ tab.
Within “Category”, select “Custom”
In the “Type” entry-box, type in the desired formatting for numbers.
Click OK button.

Format Cells shortcut number 2
Here are some keyboard shortcuts to achieve some common formats:
Two decimal places (0.00): Ctrl-Shift-!
Percent (%): Ctrl-Shift-%
Scientific: Ctrl-Shift-^

Format Cells shortcut number 3--®
Pressing Ctrl-1 on a cell will bring up the Format Cells dialog box.

Format Text within Cells--u
1.
2.
3.
4.
5.

Select the cells or range to format.
Right-click the selection and click on ‘Format Cells’
Select the ‘Font’ tab
Select the desired Font, Font Style, Size, Color and Effects.
Click OK.

Formula Auditing--n
To see graphically what cells make up a formula.
1. Click on the cell containing the formula.
2. Click the “Formulas” tab.
3. In the “Formula Auditing” section, click Trace Precedents.

Formula entry--un
You have several choices when entering formulas:
1. You can type the entire formula using the cell addresses, or
2. You can type in the formula, click on the cell addresses, or
3. You can type in the formula, pointing to the cell addresses with the arrow-keys.

Formula entry—values--n
To enter in the value of a formula instead of the formula itself, press F9 before pressing ENTER when entering the formula.

Formula Errors—Correcting--n
Suppose you have a lengthy formula that contains an error, and Excel won't let you enter it because of the error. In this case, you
can convert the formula to text and tackle it again later. To convert a formula to text, just remove the initial equal sign (=). To try the
formula again, insert the initial equals sign to convert the cell contents back to a formula.
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Formulas—Viewing--n
1.

To view the formulas instead of the data, press Ctrl-` (the key just above the Tab key). Press again to toggle back to
data.
OR
Double-click the cell with the formula (color-coded cell borders will highlight cells involved in formula)

Fractions—Displaying--®
1.
2.
3.
4.
5.
6.
7.

Click-drag to select the cells you wish to have formatted as having fractions displayed.
Right-click the selection.
Click “Format Cells”.
Click the Number tab.
Click the Fraction category.
Select the desired fraction display.
Click OK button.

Fractions—Entering--u
When entering fractions that are less than 1 into cells, precede the fraction with a zero (0) and a space. This will prevent Excel from
thinking that the fraction is a date entry. Fractions greater than 1 will not need a zero prefix.

Functions—Shortcut--n
1.
2.
3.

Click on the cell that is to contain the function.
Click on the drop-down arrow next to the Autosum button (Sigma) on the button toolbar.
Click on the desired function.

Go To--u
1.
2.
3.

Press F5.
In the Reference box, type in the cell or range address.
Click OK button.

Graphics on a Chart--®
To use your own graphics in place of Excel's built-in bars, follow these steps:
1. Create your bar chart as usual.
2. Right click on one of the data series bars in the chart. Excel displays a Context menu.
3. Choose Format Data Series from the Context menu. Excel displays the Format Data Series dialog box.
4. Click the “Fill” option on the left side of the dialog box.
5. Select “Picture or Texture Fill”.
6. Click on File button under “Insert from”. Excel displays the Select Picture dialog box, which is very similar to a standard
Open dialog box.
7. Use the controls in the dialog box to locate and select the picture you want to use.
8. Click on Insert. Excel closes the Select Picture dialog box and redisplays the Fill Effects dialog box.
9. In the Format section of the Picture tab, choose how you want the graphic to be applied to the bar. (I like to choose
Stack.)
10. Click on OK in each open dialog box to close them.

Gridlines—Color
1.
2.

Click on the Windows icon in upper-left corner.
Click on Excel Options.
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3.
4.
5.

Click the Advanced option.
In the “Display Options for this Workbook, select the desired workbook and click on the drop-down arrow next to the
Gridlines Color and select the desired color.
Click the OK button.

Gridlines on Printout--u
1.
2.
3.
4.
5.

Click on Page Layout tab.
In the Page Setup section, click the arrow in the lower-right corner.
Click the Sheet tab.
Click Gridlines.
Click OK button.

Gridlines on Screen—Turning them off
1. Click the View tab.
2. In the Show/Hide section, click the Gridlines option.
Repeat the process to turn the gridlines on again.

Grouping items in Draw mode
1. Click on first item.
2. Shift-click on all other items.
3. Click the Drawing Tools tab.
4. In the Arrange section, click Group.
The items now act as a group instead of individual items.
Headers/Footers--u
1.
2.
3.
4.

Click on the ‘Insert’ tab.
In the Text section, select ‘Header & Footer’
Enter the text you wish to appear in the blank box that appears.
Click back on your spreadsheet, and the header will appear automatically.

You have choices for Titles, date, page numbering, filename, etc.

Hiding Cell Contents--u
1.
2.
3.

Click on the cells or range to hide.
Right-click the Format menu.
Click Hide.

Home Cell--u
To move to the first cell in a spreadsheet, press Ctrl-Home.

Hyperlinks: Adding--®
To add a hyperlink to your worksheet:
1. Click on the cell where you want the hyperlink to appear.
2. Click the Insert tab.
3. Click the “Hyperlink” button.
4. In the “Text to Display” entry box, type in the wording that will hold the hyperlink.
5. In the “Address” entry box, type in the URL of the website you wish to link to.
6. Click the “OK” button.
To navigate to the hyperlink, click on the wording that holds the hyperlink.
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To select the cell, click and hold the mouse button down

IF Function--n
Used to conditionally execute a command.
1. =IF(condition, true statement, false statement) where condition is a comparison of values. In the true statement,
place the desired contents if the condition is met; in the false, place the desired results if the condition is not met.
Example: =IF(A2>1,“Yes”,“No”)

Inserting Worksheet--u
1.

Click New Sheet icon to the right of last worksheet tab.

Invalid Dates

st

When you enter in a date that doesn’t exist (i.e., April 31 ), Excel will left-align the date instead of its normal right-alignment of
dates.

ISTEXT--n
=ISTEXT(cell) returns a value of TRUE if the cell in question has text in it, FALSE if it does not.

Jump to Furthest Cell--®
1.
2.

Move cursor to edge of a cell (you will see a four-headed arrow).
Double-click

Cursor will jump to the furthest cell in the direction you selected. For example, to move to the bottom of the worksheet, point to
the bottom line of the cell. When you see the four-headed arrow and double-click, you’ll jump to the bottom of the worksheet.
Alternate method for jumping to furthest cell: Ctrl+ (up arrow or down arrow)

Last Name from a Cell--n®
=RIGHT(A1,LEN(A1)-SEARCH(" ",A1,SEARCH(" ",A1,1)))

Left Function--n
=LEFT(cell,xxx) returns the leftmost number of characters for a specified cell for a length of xxx.
For example, if the contents of cell A1 were ABCDEFG, the =LEFT(A1,4) would be ABCD.

Line Shading—Alternate Lines--®
1.
2.
3.
4.
5.

Select first row.
Select desired shading for row.
Select the first and second rows.
Click the Format Painter in the Clipboard section of the Home tab.
Click-drag from the first row down throughout the worksheet.

Linking Data between Worksheets--n
=sheet#!cell (where # is the sheet number and cell is the cell to be linked)

Loan (PMT) Functions--n
The PMT function returns the periodic payment for an annuity (such as a loan). There are a few things that we must know in order
for this function to work. To calculate the loan we must know a combination of the following
1. (rate) interest rate per period
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2. (NPER) number of payments until repaid
3. (PV) present value of the loan (amount we are borrowing)
4. (FV) future value of the money (for saving or investing)
5. (type) enter 0 or 1 to indicate when payments are due
PMT function is then entered as follows: =PMT(rate,NPER,PV,FV,type)

Maximum and Minimum functions--n
This function is used to find the maximum value found in a given range.
1. =MAX(cell range)
or =MIN(cell range)

MEDIAN function--n
1.

=MEDIAN(cell range)

Merge and Center--u
1.
2.
3.

Select the cells over the columns.
Click the Merge and Center button on the Formatting toolbar.
Type in the title you wish to have above the headings.

Moving Cells--u
1.
2.
3.

Select the cells to be moved.
Move the mouse toward the right-edge of the cells until a 4-headed arrow appears.
Click-drag to desired location.

N Function--n
=N(cell) returns the numeric value of the referenced cell without formatting applied.

Name Parsing--n®
With full name in A3, copy/paste the following:
B3: =IF(A3>"",IF(ISERROR(FIND(",",A3,1)),LEFT(A3,(FIND(" ",A3,1)-1)),MID(A3,FIND(" ",A3)+1,256)),"")
C3: =IF(A3>"",IF(ISERROR(FIND(",",A3,1)),MID(A3,FIND(" ",A3)+1,256),LEFT(A3,(FIND(" ",A3,1)-2))),"")
In the first formula, the IF function will look for a comma in A3, if one NOT found, it will copy the left-side characters until it finds a
space into a “first name” field”. If a comma IS found, it copies all characters from the space to the end of the cell.
In the second formula, the IF function will look for a comma in A3, if one NOT found, it will copy the right-side characters until it
finds a space into a “last name” field”. If a comma IS found, it copies all characters from the left-side until it hits the comma.

Numbers As Text--u
To enter numbers as text fields, precede the number with an apostrophe.
To change a range of cells to text:
1. Select the range of cells
2. Right-click the range.
3. Click on Format Cells
4. Click the Number tab.
5. Click the Text Category
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6.

Click OK button.

Open View Options
1.
2.
3.
4.

Click the Windows icon in upper-left corner.
Click Open.
From the dialog box, click the down-arrow next to the Views button (upper-right corner).
Click on the desired Open dialog box view.

Orientation--u
1.
2.
3.
4.

Choose Page Layout tab.
In the Page Setup section, click “Orientation”.
Under Orientation, select Landscape.
Click OK.

Panes—Freezing--®
To lock column and/or row headings in place:
1. Click on the cell below and/or to the right of the headings.
2. Click on the ‘View’ tab.
3. In the ‘Window’ section, select ‘Freeze Panes’.
4. Select Freeze Panes
To unfreeze panes, follow the steps above. Clicking on ‘Freeze Panes’ for a second time unfreezes the panes.
Shorter Shortcut:
Click the small rectangle above the arrow on the vertical scrollbar. Drag it down to desired location.

Paper Size--u
1.
2.
3.

Click Page Layout tab
In the Page Setup section, click Size.
Click the desired paper size.

Parse Data--®
Takes data from one cell and allows you to split it up either in fixed or delimited fashion.
1. Click the data to be parsed.
2. Click the Data tab.
3. Click Text to Columns option.
4. Make desired selections from the Wizard dialog boxes.
5. Select a destination for the data.
6. Click Finish button.

Percentages--u
When keying in data that will be formatted with a percentage point, remember to use decimal points. For example, to get a
desired result of 25%, enter in .25 and click the percent button on the toolbar.

Print area--clearing
1.
2.
3.

Click Page Layout tab.
In Page Setup section, click Print Area.
Click on Clear Print Area.

Print area—setting--u
1.
2.

Select the area you want to print.
Choose Page Layout tab.
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3.
4.

In Page Setup section, click Print Area
Click Set Print Area.

Printing Multiple Worksheets
1.
2.
3.
4.

On each worksheet, select the desired print range area.
Right-click one of the worksheet tabs.
Click on Select All Sheets.
Proceed with printing.

Print Preview Margins--u
1.
2.
3.
4.
5.

Choose Windows menu
Arrow over Print, then move to Print Preview and click.
In the Print Preview toolbar at the top of the screen, click the Show Margins button.
Across the top of the page, a row of black column handles appears. Drag the handles to the left or the right to change
the width of the columns on the page.
When your page looks the way you want it to look, click Print or Close.

Print—Range of Pages--u
1.
2.
3.
4.
5.

Click the Windows menu.
Click Print.
Click Print
In the Print Range area, select the desired beginning and ending page numbers.
Click OK button.

Print—Shortcut--u
Press Ctrl-P

Proper Case--n
If text was placed all in uppercase or lowercase letters, you can change the text to “proper case”.
1. =PROPER(range) where range is the group of cells to be changed.

Quick Access Toolbar—Add Buttons--®
1.
2.
3.
4.
5.
6.

Click drop-down arrow next to Quick Access Toolbar.
Select “More Commands”
In the “Choose Commands From” box, click on “Commands Not in Ribbon”
Click on desired button.
Click “Add” button.
Click OK button.

Quick Access Toolbar—Moving--®
1.
2.

Right-click on down-arrow next to your Quick Access Toolbar.
Click on “Show Below the Ribbon” to move it just above your formula toolbar.

Random Numbers--n
=ROUND(RAND()*xxx,0) ENTER will return a random number between 0 and xxx.
To generate random numbers between two numbers use the following formula:
=ROUND(RAND()*(b-a)+a,0) ENTER where a is the low end range and b is the high end range

Ranges—Naming--n
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1.
2.
3.
4.

Select the range of cells.
Click in the Name box (just above column A).
Enter in a name for the range
Press ENTER.

Ranges—Selecting--u
1.
2.
3.

Click on first cell in the range.
Press Shift key and hold down.
Click on last cell in the range.

Ranking Cells--n
To rank values within cells
1. Enter data into cells (for example, cells B1 through B4)
2. Use the formula =RANK(cell to rank, range of cells for ranking, 0)
For example, =RANK(B1,$B$1:$B$4,0)
This will compare the number in cell B1 against the values in cells B1-B4, ranking from highest to lowest.
Note: Make sure you use absolute referencing for the range of cells before copying down

Recently Used Files—Controlling the Number of Files Displayed
1.
2.
3.
4.
5.
6.

Click the ‘Options’ button (icon in the top left screen).
Click the ‘Excel Options’ button.
Click ‘Advanced’ from the new menu.
Scroll down to ‘Display’ options.
In the ‘Show this number of Recent Documents:’ , type in desired number of files you wish to appear.
Click ‘OK’.

Recovering a Corrupted File
1. Open a new workbook.
2. In cell A1, enter the following external reference formula: ='C:\Sheets\[Summary Data]Sheet1'!A1
If you're lucky, this formula returns the value in cell A1 of Sheet1 in the corrupt file.
3. Copy down this formula and to the right to recover as many values as you can.
4. Convert the external reference formulas in the new workbook to values and then save the workbook.
If the corrupt file has additional worksheets, repeat these steps for any other worksheets in the workbook (you need to know the
exact sheet names).

Redo--u
1.

Press Ctrl-Y.

You may click Redo multiple times to redo the options undone by undo.

References on other worksheets--n
To link a cell from one worksheet to another
1. =xyz!cell (where xyz is the sheetname and cell is the cell address. Remember the ! between the two.)

Repeat Function--n
=REPT(“text”,xxx) ENTER where “text” is the desired text to be repeated within quotation marks, and xxx is the number of
repetitions.

Repeating data in cells--u
1.

Select the cell range.
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2.
3.

Type in the value to be placed in all of the cells.
Press Ctrl-ENTER.

Repeating titles--®
1.
2.
3.
4.

Click Page Layout tab.
In the Page Setup section, click Print Titles
In the Rows to Repeat at Top box, enter in the range that includes all the desired headings.
Click OK button.

Replace--u
1.
2.
3.
4.
5.

Press Ctrl-H.
In the Find What entry box, type in the text to be replaced.
In the With What entry box, type in the desired text.
Click either the Replace or Replace All button.
Click Close button.

Repositioning--®
1.
2.
3.
4.

Click on cell(s) to be repositioned.
Click and hold mouse-button down.
Press Shift-key.
Move mouse to desired location and release button.

Retrieving non-Excel file types--u
1.
2.
3.
4.
5.

Click the Windows button.
Click Open.
Click the drop-down arrow next to Files of Type.
Click the desired file type to see those files listed.
Click once on the desired file icon and press Open button (or double-click the icon).

Ribbon Scroll
You can scroll through your ribbons by pointing in ribbon area and moving your scroll button.

Ribbon Shrink (or Expand)-- ®
1.

Double-click on a ribbon tab to only see the tabs (and no commands). Double-click again to have them reappear.

Roman Numerals--n
1.

=ROMAN(“yyyy”,0) where yyyy is a four-digit year

Round Function--n
=ROUND(cell,xxx) where cell is the cell with the data value and xxx is the number of decimal places to round to.

Row Delete--u
1.
2.
3.

Select the row(s) to delete.
Click ‘Home’ tab.
In the Cells section, click ‘Delete’

Row Hide--u
1.
2.
3.

Select the row(s) you want to hide.
Select the ‘Home’ tab.
In the ‘Cells’ section, click Format button.
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4.

A dropdown will appear, select ‘Hide&Unhide’- Hide Rows.

Row Insert--u
1.
2.

Select the rows where you want the insertion to take place.
In the Cells section, click ‘Insert’

Row Size—Changing--®
1.
2.

Point with the mouse between rows until a double-headed arrow appears.
Click-drag to make the row narrower or wider.

Saving Files as another format--u®
1.
2.
3.
4.
5.
6.

Click the Office button (the icon in the top left of your screen).
Position mouse over “Save As”.
In the dropdown that appears, select ‘Other Formats’
Click the down arrow on the ‘Save as type’
Click the format you would like the file saved as.
Click the ‘Save’ button.

Saving Files to another form of media--u
1.
2.
3.
4.
5.
6.

Click the Office button (the icon in the top left of your screen).
Position mouse over “Save As”.
In the dropdown that appears, select ‘Other Formats’
Click the down arrow on the ‘Save-in’ bar.
Click on desired location.
Click the Save button.

Selecting Cells Above/Below Current Cell--®
Ctrl+Shift+ (Up arrow or down arrow) to select all of the cells above or below the current cell

Selecting the Contents of Entire Worksheet--®
1.
2.

Click on the last cell.
Press Ctrl-Shift-Home.

Selecting the Contents of Current Region--®
1.

Press Ctrl-Shift-8.

Selecting the Entire Worksheet--u
1.
2.

Click Ctrl-A
or
Click the box to the left of column A and above row 1.

Sorting--u
1.
2.
3.
4.

Click somewhere within the data area to be sorted. Make sure there are no blank columns in the data area.
Click on the Home tab.
In the Editing section, click on Sort & Filter
Select the desired sort order or click Custom Sort and make selections in the dialog box.

Speak Cells (and Stop Speaking Cells)-- ®
1. Select cell(s) and click the “Speak Cells” button on Quick Access Toolbar.
(see Quick Access Toolbar—Add Buttons” to add these buttons)
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Special formats--®
1.
2.
3.
4.
5.

Select the cell or column of cells for the special format.
Right-click the cells/column and choose Format Cells from the shortcut menu.
Click the Number tab.
Select the desired Category and format.
Click OK.

Statistics Magic--®
1. Select range (or group) of cells.
2. Look at Status Bar at bottom of spreadsheet. It contains COUNT, SUM, AVERAGE, MIN, and MAX.
Configurable by right-clicking Status Bar and selecting the desired features.

Subtotal--®
1.
2.
3.
4.
5.
6.
7.
8.

Sort spreadsheet by the field you wish to use in the Subtotal.
Click on the Data tab.
Click on the Subtotal icon within the Outline group.
Make a selection in the “At each change in” (typically this is the field you sorted on)
Select the desired function from the drop-down menu.
Determine the field(s) for the subtotal to use.
Make sure “Summary below data” is checked.
Click OK button.

SUM function using Ranges--n
1.
2.

Click on cell where you want the sum of a range of numbers to appear.
=SUM(cell A:cell B) where cell A is the beginning of the range and cell B is the ending of the range.

SUM function using Titles--n
1.
2.

Click on the cell at the bottom or right of the range of cells to be summed.
=SUM(range name) ENTER will total the cells within the named range.

For example, if the name of the range was "March", type in =SUM(Bill) for the function.

Swap Columns--®
1.
2.
3.
4.

Select column to be moved.
Position cursor on border of the range (you will see a four-headed arrow).
Press and Hold down SHIFT key.
Drag to desired location and release mouse button.

Symbols
1.
2.
3.
4.
5.

Select the ‘Insert’ tab.
In the Text section, click on the ‘Symbol’ icon.
Click the desired symbol (including font size) from the table that appears.
Click ‘Insert’.
Click ‘Close’.

Table Creation:-- ®
1.
2.
3.

Click anywhere within the data range.
Press Ctrl-T.
Press OK.
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You can select formatting options if you wish from the ribbon.

Text Alignment--u
1.
2.
3.
4.
5.
6.

Select the cell(s) to be aligned.
Right-click the cell(s).
Click on Format Cells.
Click the Alignment tab.
Under Orientation, Text Control or Text Alignment, make any desired changes.
Click OK.

Text Box--u
1.
2.
3.

Click on the Insert tab.
In the Text section, click theText Box tool.
Using the crosshairs, size the box on the spreadsheet using a click-drag method from one corner to the opposite
corner.
4. Key in text
Double-clicking the border of the text box allows the user to format the text, the border and other features.

Text Colors--u
1.
2.
3.

Select the cell(s) to be changed.
Click the Home tab.
Click the Font Color tool on the toolbar (for more color choices, click the drop-down arrow next to the button).

Text Wrapping--®
1. Select the cell(s) to be aligned.
2. Right-click the cell(s).
3. Click on Format Cells.
4. Click the Alignment tab.
5. Under Text Control, selected Wrap Text.
6. Click OK.
Note: Press Alt-ENTER to force a carriage return within a wrapped cell.

Time--n
1.
2.

Press Ctrl-Shift-: (colon)
or
=NOW()-TODAY() ENTER (you will need to format the cell for Time)

TODAY function--n®
1. =TODAY() will put today’s date into the cell.
Shortcut for entry of today’s date: press Ctrl-; (semi-colon) for the date or Ctrl-: (colon) for the time

Trace Error--n
If you see an exclamation point when you enter in a formula (or a green triangle), click the drop-down arrow to see choices on how
to correct the error.

Transpose--®
To change the horizontal rows and vertical columns of your data.
1. Select the cells to be changed.
2. Press Ctrl-C.
3. Right-click on the desired location for the transposed data.
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4.
5.
6.

Click on Paste Special.
Click on the Transpose checkbox.
Click OK.

TRIM Function--n
To remove trailing spaces from text in a cell.
1. =TRIM(cell)

TYPE Function--n
=TYPE(cell) returns a value of 2 if the cell in question has text in it, 1 if it has a numeric value.

Undo--u
1. Press Ctrl-Z.
You may click multiple times to undo several actions.

VLOOKUP Function--n
1. =VLOOKUP(cell,range of lookup table,column to return)
For example the function =VLOOKUP(A1,M1:N8,2) would take the value of cell A1 and evaluate it in the range from M1-N8
and return the value from the second column (N).

Window—Split
1.
2.

Click View tab.
In the Window section, click Split.

WordArt
1.
2.
3.
4.

Click the Insert tab.
In the Text section, click WordArt.
Click on the style of letters you wish.
In the WordArt section, make desired selections to change the appearance of the text.

Worksheet Tabs—Coloring--®
1.
2.

Right-click a tab to color.
Arrow over Tab Color and move into palette and select color.

Worksheet Tabs—Naming--u
1.
2.

Double-click the tab name.
Type in desired name and press ENTER.

Worksheets—Add--u
1.

Press Shift-F11 or click the (short) tab on the right of the tabs.

Worksheets—Copying
Hold down Ctrl-key as you click-drag a worksheet tab to a new location. The worksheet will create a copy at the new
location. It will contain the same worksheet name with a “(2)” suffix. You can change the worksheet name if you wish.

Worksheets—Delete--u
1.
2.

Right-click on the tab of the worksheet to delete.
Click Delete.
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Worksheets—Moving--u
Click-drag the worksheet tab and drag it left or right to the desired location.

Worksheets—Moving within (shortcuts)
Use the Ctrl key with the arrow keys to move to the ends of the worksheet page.

Worksheets—Moving between Sheets--®
Press Ctrl-PageDown to move forward to the next worksheet.
Press Ctrl-PageUp to move backward to the previous worksheet.

Zoom
1.
2.
3.

Click the Windows button.
Move mouse over Print and slide mouse to right and click Print Preview.
Click on area to be "zoomed" or click the Zoom button.

Button acts as a toggle switch; when pressed a second time, you will "un-zoom" the area.

Al Momrik (amomrik@leveldata.com)
Level Data, Inc., 4787 Campus Drive, Kalamazoo, Michigan 49008

